通达信macd缠论选股,通达信MACD上穿选股公式

内容导航:
  • 通达信MACD上穿选股公式
  • 请高手帮忙编一个通达信60分钟MACD金叉的自动选股公式!
  • 谁能帮我编个macd底背离的选股公式,不盛感激!
  • 求助缠论macd面积选股
  • 请高手把这个公式改成通达信选股公式,选出当天出现的【黑马起爆点】信号的股票,急需,谢谢!!!
  • 请按照下面指标源码做个选股公式,谢谢!
  • Q1:通达信MACD上穿选股公式

    X1:=BARSLAST("MACD.DEA"<0);
    X2:=CROSS("MACD.MACD",0);
    X3:CROSS(COUNT(X2,X1),0.5) AND X1>0;

    Q2:请高手帮忙编一个通达信60分钟MACD金叉的自动选股公式!

    LONG :=26;
    SHORT :=12;
    M :=9;
    DIFF :=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
    DEA :=EMA(DIFF,M);
    MACD :=2*(DIFF-DEA), COLORSTICK;
    cross(DIFF,DEA);
    在时间上选择60分钟就可以
    另外这个只能选择正在穿过的,而不能选择已经穿过1小时或者2小时的股票。你可以选择diff在dea上方的股票,也就是可以这样写:
    LONG :=26;
    SHORT :=12;
    M :=9;
    DIFF :=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
    DEA :=EMA(DIFF,M);
    MACD :=2*(DIFF-DEA), COLORSTICK;
    DIFF>DEA;

    Q3:谁能帮我编个macd底背离的选股公式,不盛感激!

    MA1:=MA(CLOSE,5);
    MA2:=MA(CLOSE,10);
    DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
    DEA:=EMA(DIF,MID);
    MACD:=(DIF-DEA)*2,COLORSTICK;
    DIFF:=SUM(MA1-MA2,0);
    SUMMACD:=SUM(MACD,0);
    W1:=BARSLAST(CROSS(MA2,MA1))+1;
    W2:=BARSLAST(CROSS(MA1,MA2))+1;
    W3:=BARSLAST(CROSS(MACD,0))+1;
    W4:=BARSLAST(CROSS(-MACD,0))+1;

    趋势力度:IF(K,SUMMACD-REF(SUMMACD,MIN(W3,W4)),DIFF-REF(DIFF,MIN(W1,W2)));
    趋势平均力度:趋势力度/IF(K,(MIN(W3,W4)+1)/20,(MIN(W1,W2)+1)/20),COLORSTICK;
    MAX趋势平均力度:HHV(趋势平均力度,34);
    MIN趋势平均力度:LLV(趋势平均力度,34);
    --------------------------------------------------------------------------------------------------------------------------------------------
    K值可调,调成“0”是通过均线缠绕面积判断背驰
    调成“1”是通过macd面积判断背驰。
    白线为均线(或macd )到目前为止的面积,白线的拐点(即某一段的最大值(绝对值))是均线或macd面积。如果K调成1,红绿柱为凭据趋势力度。

    此指标不是选股指标,是个副图指标,因为选股指标需要判断前后面积的大小,难度极大,不易做出,目前还没发现有人能写出来。

    Q4:求助缠论macd面积选股

    缠师回答过这个问题。一般目测即可。如果要精确的,请复习一个微积分公式。
    macd只是辅助判断。要判断背驰或盘整背驰,首先要划分中枢,找到要比较哪两段的力度,然后再用macd来比较。这个顺序不能颠倒。
    如果你要公式来程序化交易,那么前提是电脑可以准确划分中枢。但这并不是电脑这样的机械思维可以做到的,因为中枢的划分是动态的,灵活的。这是走势分解的多义性,注意多义性不是模糊性。

    Q5:请高手把这个公式改成通达信选股公式,选出当天出现的【黑马起爆点】信号的股票,急需,谢谢!!!

    VAR1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;

    VAR2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;

    VAR3:=SMA(VAR2,2,1);

    天:100+(-ABS(VAR1)),COLORRED;

    下:SMA(VAR3,2,1);

    无:ABS(VAR1),COLORGREEN;

    敌:50,COLORFFAA00,LINETHICK3;

    A:80;

    B:20;

    买:STICKLINE(CROSS(下,无),3,20,2,0),COLORRED,LINETHICK1;

    STICKLINE(CROSS(下,无),20,25,2,0),COLORFF9900,LINETHICK1;

    DRAWTEXT(CROSS(下,无),30,'黑马起爆 '),COLORFFFFCC;

    卖:STICKLINE(CROSS(下,天),70,90,2,0),COLORRED,LINETHICK1;

    STICKLINE(CROSS(下,天),90,99,2,0),COLORFF9900,LINETHICK1;

    DRAWTEXT(CROSS(下,天),70,'走人 '),COLORFFFFCC;

    选股2:IF(CROSS(下,20),1,0);

    DRAWICON((CROSS(下,20) ),20,1);

    DRAWICON((CROSS(下,20) ),-20,25);

    =============================

    {选股}

    VAR1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;

    VAR2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;

    VAR3:=SMA(VAR2,2,1);

    下:=SMA(VAR3,2,1);

    无:=ABS(VAR1);

    XG:CROSS(下,无);

    Q6:请按照下面指标源码做个选股公式,谢谢!

    VOLUME:=VOL;
    MA1:=MA(VOLUME,5);
    启动:= (MA1+MA1)>VOLUME;
    买入:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND CLOSE>=HHV(HIGH,10)
    AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85) AND C>O;
    选股:(C>REF(HHV(H,3),1) AND (C-REF(C,1))/REF(C,1)>0.07) AND 启动 AND 买入;

    上一篇:上一篇:金力泰最新消息
    下一篇:下一篇:每2股变为5股
    • 评论列表

    发表评论: